ANN: OneCare Has Automated Windows Mobile Connectivity Killer

I have previously written about the fact that OneCare killed the connectivity with my Windows Mobile device. Now I got a OneCare update installed yesterday (I think it was yesterday) (oh yes, and I loved that “OneCare is going to reboot your system in 4 hours” dialog… WTF? What if wasn’t there over the weekend or something? Can you spell “loss of data”, Microsoft?) and so I thought today I’d just try whether the issue had maybe been fixed.

Previously I had just disabled the firewall while on my secured home network and synced my phone – not nice, but it worked. Now read this message carefully:

Wow! Ain’t that peculiarfantastic! So not they’ve done it: I can’t use my Windows Mobile device with my computer because of my firewall, and when I switch off the firewall and connect the device, the firewall automatically reactivates to protect me from the device! Let me repeat that: Wow!

So, the good news is that there’s an option “Automatically change my Firewall protection level when I connect to an unsecured network”. But this was already there in the previous version of OneCare, without the same effect… so obviously they changed something about the Windows Mobile connectivity thing, just not the right thing. Plus, I don’t really want to turn off that option, it’s a good option… oh, f#$k it.

(5 minutes later)

Even with that option switched off, I still can’t make my phone connect… it used to work only a few days ago, so I wonder if there’s still something in the way, even though the firewall is now switched off (and stays switched off). Guess I’ll have to fiddle around, reboot, that kind of thing, to be sure – I’ll do that later.

Update: I have now rebooted and tried again, and as long as the firewall and the option are switched off, I can now connect and synchronize my phone again. Magic. There are currently at least two bug reports on Microsoft’s Connect site: here and here. As is often the case, there doesn’t seem to be any reaction to these issues though. One of the things I hate about beta software from MS, I must admit: there’s never any direct contact with the responsible people.

Sorry, this blog does not support comments.

I used various blog hosting services since this blog was established in 2005, but unfortunately they turned out to be unreliable in the long term and comment threads were lost in unavoidable transitions. At this time I don't want to enable third-party services for comments since it has become obvious in recent years that these providers invariably monetize information about their visitors and users.

Please use the links in the page footer to get in touch with me. I'm available for conversations on Keybase, Matrix, Mastodon or Twitter, as well as via email.