Electric Editing now with VS 2010 support

Version 1.2.4.1 of Electric Editing is now available here:

CR_ElectricEditing-1.2.4.1.zip (22610 bytes)

This build is compiled against DXCore 10.1.7, and tested in Visual Studio 2008 as well as 2010. Enjoy!

Oh, and of course if you don’t have a clue what Electric Editing is, check out this overview with the various posts linked from there!

8 Comments on Electric Editing now with VS 2010 support

  1. Christopher Bradford // November 4, 2010 at 4:09 pm // Reply

    Excellent! Thank you. Working great for me.

    Like

  2. Good to hear – I’ve seen some trouble in a VM of mine where the whitespace hinting seems to leave artefacts on screen… might have to look into that, although it wasn’t particularly bad. Otherwise no known issues at this time – let me know if you find something!

    Like

  3. Christopher Bradford // November 8, 2010 at 4:31 pm // Reply

    I haven’t really used the whitespace hinting, but I’ll turn it on and see if I see the artefacts.

    Like

  4. I’ve just tried installing electric editing in coderush 10.2.5 to use in both VS2008 & 2010, but it’s not working for me at all. When I go to core>plugin manager on the options screen, selecting different plugins (including instant gratification) shows up a bunch of info in the category and item column in the far right hand pane, for electric editing this is completely empty. This is the same in both 2008 and 2010. There is no options screen for it, and none of the functionality seems to be happening.

    If I get hold of the previous version it crashes as expected from earlier comments, but with the latest it just fails silently. If it makes a difference, this is running windows server 2008 r2. Do you have the source available publically anywhere? I’d be happy to have a crack at debugging it myself if you’re busy or can’t replicate the problem.

    Like

  5. I just tried this with coderush 10.2.5 and the plugin just wont load. Unfortunately I never had a chance to try this with 10.2.4 to verify it did actually work.

    Like

  6. Well, what does it do? I use it with 10.2.5 myself and it works just fine. Send me email if you want to discuss.

    Like

  7. Okay, I’m working on it… I never realized that the one machine where I use the plugin a lot myself was still running on 10.1 – 10.2 breaks all sorts of things with references. Will publish a new version in a little while (hours, not longer).

    Like

  8. An update is now available.

    Thanks for your patience, and for reporting the issues!

    Like

Leave a Comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s