CopySourceAsHTML and VS 2008 SP1

I tried to install the very nice CopySourceAsHTML (the link hasn’t actually been working for me since yesterday, but I had a download hanging around) plugin on my machine, which has both VS 2005 and VS 2008 (the latter including the new SP1) installed. I chose to install “for everybody”, as I always do – perhaps this makes a difference, I haven’t tried. This is an XP machine.

The plugin didn’t install itself correctly for some reason, not even in VS 2005. I found the file CopySourceAsHTML2005.Addin in the path C:Documents and Settings<username>Application Data, where I didn’t think it belonged – and VS was obviously not finding it there either. When I moved it into C:Documents and Settings<username>My DocumentsVisual Studio 2005Addins, VS 2005 found it but couldn’t load it – there was an error message on VS startup. I found that I had to copy the file CopySourceAsHTML2005.dll into the same directory and then it worked (that dll got installed in C:Program FilesJ.T. Leigh & AssociatesCopySourceAsHtml2005). Weird.

I also made it work in VS 2008 by copying the Addin and the dll files to C:Documents and Settings<username>My DocumentsVisual Studio 2008Addins and changing the version number in the Addin file to 9.0. Now everything works fine in both VS versions. The installer is apparently not quite up to scratch… nice plugin though!

Leave a Comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s