Lightroom requires a Live ID to import pictures?

I had the weirdest problem a moment ago and I found a solution that I thought I’d document for myself and anybody else who sees that issue. I was trying to use Abode Lightroom to import a bunch of pictures from my camera. I was going to have the pictures copied to a folder on a network drive. Lightroom uses a folder selection dialog to browse for the right folder. When I clicked on the entry “Computer” in the hierarchy, this dialog popped up (actually it took a little while to come up, for some reason):

lightroom-liveid-login

At the same time, Lightroom hung and I wasn’t able to get it to do anything at all, so I had to kill it. Anyway, of course I wouldn’t have wanted to enter a Live ID for the purpose of storing a few pictures to my server. Weird.

I looked into the issue and also found some hints in German language here. The problem is the folder “My Web Sites on MSN” – an entirely useless thing (or at least one whose purpose I’m not aware of <g>), which can be seen in an Explorer window:

websites-on-msn-explorer

I’m not aware of the reason why Lightroom has such special problems with that virtual folder – it’s been around forever, I think, but I’ve never had the same Live ID login problem. Anyway, thankfully it’s easy to get rid of that folder once you find where it’s actually stored. In Vista, the path is C:Users<username>AppDataRoamingMicrosoftWindowsNetwork Shortcuts, in older Windows versions you’d have to look for a folder called “Nethood” in your user profile (the name will be translated if your version of Windows is not an English language one). In that folder I found the link for the MSN sites:

network-shortcut-msn-sites

I deleted that link and immediately Lightroom behaved properly, showing me the drives and other entries underneath “Computer” correctly in the folder browse dialog.

The German language page I linked above mentioned that there might also be registry keys in the path HKEY_CURRENT_USERSoftwareMicrosoftWeb Service Providers, which might also have to do with the issue. I found a few keys in there that didn’t seem obviously connected, so I left them. If I ever see the problem again, I might still look here for some more stuff to get rid of.

5 Comments on Lightroom requires a Live ID to import pictures?

  1. Running Vista too but don’t have that MSN sites nonsense (I remember it in XP). Maybe it was snuck onto your system when installing some Windows Live stuff such as Windows Live Writer?

    Like

  2. Yes, that’s possible – I do have Windows Live Writer installed. In any case it didn’t surprise me to find it there, as I had seen it many times before. No idea where exactly it comes from.

    Like

  3. This solution worked perfectly for me! Thanks!

    Like

  4. I did not have this folder before. Then I saw it. I did not install anything.Where did it come from?

    Like

  5. Thanks a mill for explaining this irritation,has broken my heart all day til now

    Like

Leave a Comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s